• Welcome to our Forum! Ask PC-Build Questions, discuss Tech-News, Content Creation & Gaming Workloads or get to know the CGDirector Community off-topic. Feel free to chime in with insight or questions on any existing topic too! :)

Maxing out CPU/GPU issue?

youngy89

youngy89

New member
Joined
Dec 21, 2020
Messages
6
Reaction score
0
Points
1
Hi all,

Apologies if this is off topic, but I am running into an issue within C4d and this community really knows their stuff. I have an issue where the viewport within C4d R23 just turns completely red, and no matter what I do nothing brings it back from this vivid shade of rouge! I wonder if I am hitting the maximum the GPU/CPU can handle and is effectively giving me the 'blue screen of death', but red in this case.

Has anyone had anything like this themselves? Or could you point me in the right direction?

Thanks!
TomScreenshot 2021-05-06 at 20.02.38.png
 
Jerry James

Jerry James

Hardware Nerd @ CGDirector
Staff member
Joined
Jun 19, 2020
Messages
287
Reaction score
91
Points
28
Oh wow, that looks like death indeed.
What system hardware do you have and could you also check the graphics card driver version you're using?
I've heard about these issues and it's almost always graphics driver related or a recent Windows Update breaking something within C4D for some users.
 
youngy89

youngy89

New member
Joined
Dec 21, 2020
Messages
6
Reaction score
0
Points
1
Thanks for the reply Jerry. It certainly does! 😭

Interestingly I am on Mac, so I can't update drivers for my graphics card. My system is as follows:
Mac OS 10.15.6 Catalina (can't update to Big Sur just yet due to software compatibility issues)
CPU - 2.4 GHz 8-Core Intel Core i9
RAM - 32 GB 2400 MHz DDR4
GPU - Radeon Pro Vega 20 4 GB / Intel UHD Graphics 630 1536 MB

I think this may push me to pull the trigger on buying a new PC - but without knowing for certain what it is, I'm cautious on paying a few thousand for a PC that actually doesn't fix the issue above.
 
Alex Glawion

Alex Glawion

CG Hardware Specialist @ CGDirector
Staff member
Joined
Jun 12, 2020
Messages
654
Reaction score
120
Points
43
Wow I've never seen this before. Have you tried playing around with your display-settings in the preferences? Might be some weird combo. Also reset your user preferences (just rename your user pref folder) to test if anything is weird there.
 
youngy89

youngy89

New member
Joined
Dec 21, 2020
Messages
6
Reaction score
0
Points
1
Hey again,

I think I've figured it. So the file that I was working on was an old project I did just before Christmas without any issues. So I asked myself if anything else had changed in my system setup. The only thing that had changed was the incorporation of a 4k monitor. So after unplugging it and just using my laptop's own screen, I've not had any issues (yet).

So if my 4k screen is to blame. Does that mean the GPU is being put under too much load and effectively 'stalls'? I thought the C4d Viewport wasn't necessarily impacted by GPU, but more the CPU...
 
Alex Glawion

Alex Glawion

CG Hardware Specialist @ CGDirector
Staff member
Joined
Jun 12, 2020
Messages
654
Reaction score
120
Points
43
The GPU is still responsible for outputting to the displays, no matter what goes on in the viewport complexity-wise. So it might very well be that the 4k monitor is straining the GPU more than before.
 
Top